[Gothic 3] Performance-Tweaks

Despair

Bekanntes Gesicht
Mitglied seit
21.08.2006
Beiträge
1.603
Reaktionspunkte
0
Website
cynamite.de
Nach langem Ausprobieren habe ich einen guten Kompromiss zwischen Optik und Leistung für mein System herausgefunden (Athlon XP2800+, 1 GB RAM, Geforce 6600GT [128 MB]). Sollte auch auf anderen schwächeren Rechnern mit 1 GB RAM helfen:

Nvidia Treiber 91.47: Hardware Rendering auf „Leistung“ setzen.
Coolbits oder DetonatorUnlock installieren und in den erweiterten Direct3D-Einstellungen "Max. Bilder im Voraus rendern" auf 0 setzen.

Windows Auslagerungsdatei: 1536 MB

Gothic 3 Einstellungen:
Auflösung: 1024x768
Entfernung: Mittel
Resource-Cache: Mittel
Objektdetails: Mittel
Shaderqualität: 2.0
Texturqualität: Mittel
Texturfilterung: Anisotropisch
Vegetationsqualität: Niedrig
Schattenqualität: Aus
Post-Processing: Aus

Sound: Mono (:()

Der folgende Tweak der ge3.ini (vor dem Tweaken ein Backup machen!) stammt von Pho aus dem World Of Gothic-Forum und hat bei mir die Häufigkeit der Nachladeruckler reduziert:

ResourceCache.u32ImageMaxMemUsage_Medium=96000000
ResourceCache.u32MeshMaxMemUsage_Medium=40000000
ResourceCache.u32SoundMaxMemUsage_Medium=20000000
ResourceCache.u32MaterialMaxMemUsage_Medium=21000
ResourceCache.u32CollisionMeshMaxMemUsage_Medium=17000000
ResourceCache.u32AnimationMaxMemUsage_Medium=35000000
ResourceCache.u32SpeedTreeMaxMemUsage_Medium=750000

Dann habe ich noch die Ragdoll-Effekte etwas runtergeschraubt:

Animation.MaxRagDolls=800

Das Spiel lief mit diesen Einstellungen mehrere Stunden am Stück problemlos.
 
Zuletzt bearbeitet:
Edu schrieb:
Stells mal auf hoch. Dann müsstes noch besser laufen.

Das trifft vielleicht auf Rechner mit 2 GB RAM zu, auf meinem System sorgte Resource-Cache auf hoch für schlechtere Performance und Abstürze...
 
Zuletzt bearbeitet:
Ragdoll heißt übersetzt Stoffpuppe und simuliert das Bewegungsverhalten von unbelebten Körpern ;)
Das ist das, was du siehst, wenn du bei Gothic 3 jemanden zu Klump haust und der dann realitätsgetreu zu Boden fliegt.
 
Despair schrieb:
Der folgende Tweak der ge3.ini (vor dem Tweaken ein Backup machen!) stammt von Pho aus dem World Of Gothic-Forum und hat bei mir die Häufigkeit der Nachladeruckler reduziert:
diese Einstellung habe ich heute abend mal getestet (da ich auch mit einem 1GB-System geplagt bin :rolleyes: ): funktioniert ganz gut und es wird tatsächlich nicht mehr ganz so oft nachgeladen.
 
Omega schrieb:
diese Einstellung habe ich heute abend mal getestet (da ich auch mit einem 1GB-System geplagt bin :rolleyes: ): funktioniert ganz gut und es wird tatsächlich nicht mehr ganz so oft nachgeladen.

War auch überrascht, dass der Tweak so gut funktioniert.

Kleine Erweiterung für Besitzer von Nvidia-Karten (siehe #1).
 
Wie kann ich denn, nachdem ich den registry-Eintrag von Coolbits installiert habe, in das Menü gelangen, wo ich "Max. Bilder im Voraus rendern" einstellen kann?
 
Malkavian Kindred schrieb:
Wie kann ich denn, nachdem ich den registry-Eintrag von Coolbits installiert habe, in das Menü gelangen, wo ich "Max. Bilder im Voraus rendern" einstellen kann?

"Leistungs- und Qualitätseinstellungen", dann "Weitere Direct3D-Einstellungen".
 
Ich vermute das die Resource Cache High Einstellung etwas damit zu tun hat wieviel und wann er etwas auf Festplatte auslagert.
In diesem Fall ist dementsprechend nicht entscheidend ob du 1 oder 2 Gig hast, wobei natürlich wesentlich mehr ausgelagert wird solang du nur 1 Gig hast.
Bei mir führte die Einstellung zu einem Performancegewinn, zumindest bilde ich mir das ein. Die Nachladeruckler sind meine ich weniger gewurden. Auch ich besitze nur 1G aber 2 Festplatten im Raid verbund und hab auf der Seite halt ein Paar Vorteile weil er doch einiges an Daten laden kann.

Ist aber nur ne Vermutung.
 
Malkavian Kindred schrieb:
äh... Wie komme ich in dieses Menü überhaupt rein?

Du gehst in der Menüleiste auf "Anzeigen" und wählst "Klassisches Nvidia-Control Panel verwenden" aus. Dann das Control-Panel neu starten. Auf der linken Seite wirst du fündig.

Das neue Control-Panel gefällt mir nicht, da finde ich nie etwas... :D
 
Geht mir auch so ^^
Son DAU bin ich nämlich eigentlich auch nicht, nur das neue Control Panel hat mich verwirrt :D
Edit: Ja, jetzt kenn ich mich wieder aus ^^
 
Impact schrieb:
Ich vermute das die Resource Cache High Einstellung etwas damit zu tun hat wieviel und wann er etwas auf Festplatte auslagert.
In diesem Fall ist dementsprechend nicht entscheidend ob du 1 oder 2 Gig hast, wobei natürlich wesentlich mehr ausgelagert wird solang du nur 1 Gig hast.
soweit mir bekannt ist, wird der Resource Cache benutzt um Objekte der näheren Umgebung in den RAM zu laden, damit sie schneller abrufbereit sind. bei 1GB RAM wird die mittlere Einstellung empfohlen, die Einstellung hoch nur für Rechner ab 2 GB.
 
Hmm teste das noch mal aus aber das Tweaken hat denk ich auch bei mir a bissle was gebracht.:) Alles in allem läufts mittlerweile ganz gut.
 
Die Tweaks haben tatsächlich ein Bissl Abhilfe geschaffen, wirklich toll läufts aber immer noch nicht. Aber wenigstens etwas spielbar.

Danke dir für die Tipps :hoch:
 
Azzi schrieb:
Die Tweaks haben tatsächlich ein Bissl Abhilfe geschaffen, wirklich toll läufts aber immer noch nicht. Aber wenigstens etwas spielbar.

Danke dir für die Tipps :hoch:
Zu deinem hässlichen Wasser:
Hast du in der ge3.ini manuell Shader 3.0 eingestellt? War bei mir nämlich auch nur auf 2.0. Bei 3.0 sehen zumindest die Flüsse gut aus.
 
Zurück